Então, minha conexão possui autenticação no roteador e meu modem em modo bridge, porém um dia precisei configurar a autenticação no computador para poder disponibilizar via meu servidor de DynDNS com a porta 80 o acesso ao meu PC (da pasta /var/www), utilizando o Servidor Apache, para isso configuei meu Roteador também em modo Brigde e depois utilizei o comando

pppoeconf

Após configurado, aê sim, ao digitar o endereço do meu DynDNS, batia na porta 80 do meu PC e não mais no Roteador (Utilizando o No-IP) .Depois que utilizei, decidí voltar a configuração pro Roteador (reconfigurei o Roteador para modo Router e conectou), porém após reiniciar o PC, a máquina não conectava mais na Internet, então fiz o seguinte para reconectar

E então, conseguí reestabelecer conexão com a Internet. Porém toda vez que eu reiniciava meu PC, as configurações eram perdidas, cheguei até a criar um Script para não perder muito tempo

#!/bin/bash
echo Livre Xpert TI irá reconfigurar sua rede, pressione ENTER para iniciar a configuração, ou Ctrl+c para desistir
read resposta
ifconfig
ifconfig eth0 down
ifconfig eth0 10.1.1.2 netmask 255.0.0.0 up
echo nameserver 10.1.1.1
route add default gw 10.1.1.1 dev eth0
ifconfig
ping -c4 www.google.com

Mas isso tava me enchendo o saco, então procurei minhas configurações de standart automático, e encontrei no seguinte endereço

vim /etc/network/interfaces

E estava com a seguinte configuração

auto lo
iface lo inet loopback
auto dsl-provider
iface dsl-provider inet ppp
pre-up /sbin/ifconfig eth0 up # line maintained by pppoeconf
provider dsl-provider
auto eth0
iface eth0 inet manual

E então alterei para

auto lo
iface lo inet loopback
iface eth0 inet static
address 10.1.1.2
netmask 255.0.0.0
gateway 10.1.1.1
auto eth0

Pronto, não tive mais problema, fácil, né?Abraço a todos e até a próxima!